OK, turing.

<- leave blank

Thu Oct 19 00:11:43 EDT 2017

/usr/lib/pcc/x86_64-unknown-linux-gnu/1.2.0.DEVEL/lib/crt1.o: In function
`_start':
crt1.c:(.text+0x9): undefined reference to `_DYNAMIC'
/usr/lib/libc.a(__init_tls.lo): In function `static_init_tls':
__init_tls.c:(.text+0x1ca): undefined reference to `_DYNAMIC'
__init_tls.c:(.text+0x1d7): undefined reference to `_DYNAMIC'
ld: a.out: hidden symbol `_DYNAMIC' isn't defined
ld: final link failed: Bad value
error: ld terminated with status 1


Wed Oct 18 03:16:01 EDT 2017
du -n /mnt/term/d:/music/dirtlabaudio | sed 's/^[0-9]+ //'
87935786 /mnt/term/d:/music/dirtlabaudio/01-concord_dawn-the_chaos_mix.mp3
60365427 '/mnt/term/d:/music/dirtlabaudio/Dirt Lab Audio 2012/34 DJ Vyper presents
The Dark Vaults - 05 12 07.mp3'
59520313 '/mnt/term/d:/music/dirtlabaudio/Dirt Lab Audio 2012/Bastard -
BastardLiveatDarkWaxRadio10.mp3'
56436610 '/mnt/term/d:/music/dirtlabaudio/Dirt Lab Audio 2012/Brainwash Mistic -
Dark Wax Show episode 5.mp3'
56994205 '/mnt/term/d:/music/dirtlabaudio/Dirt Lab Audio 2012/Brainwash Mistic -
DarkWaxRadioShow28 10 09.mp3'
57329826 '/mnt/term/d:/music/dirtlabaudio/Dirt Lab Audio 2012/Cem Tarakci -
darkwaxradiocom.mp3'
60808464 '/mnt/term/d:/music/dirtlabaudio/Dirt Lab Audio 2012/Cem Tarakci -
wwwdarkwaxradiocom(1).mp3'
136371722 '/mnt/term/d:/music/dirtlabaudio/Dirt Lab Audio 2012/Dj Trouble -
DirtlabAudio.mp3'
118701244 '/mnt/term/d:/music/dirtlabaudio/Dirt Lab Audio 2012/DJ_KURRUPT -
kurrupt Current Value Mix2011.mp3'
81731500 '/mnt/term/d:/music/dirtlabaudio/Dirt Lab Audio
2012/Fade_live_on_darkwaxradio.com260309.mp3'
43931274 '/mnt/term/d:/music/dirtlabaudio/Dirt Lab Audio 2012/Fexomat -
Fexomat_HKV_vs_TNI_Zurich_2008.mp3'
705516 '/mnt/term/d:/music/dirtlabaudio/Dirt Lab Audio 2012/Intermission 4
featuring Mistic - Dark Hado.mp3'
597263 '/mnt/term/d:/music/dirtlabaudio/Dirt Lab Audio 2012/Intermission 4
featuring Mistic - Smack To The Face feat Dark Wax Kru.mp3'
843860 '/mnt/term/d:/music/dirtlabaudio/Dirt Lab Audio 2012/Intermission 4
featuring Mistic - Techno Funk.mp3'
64371148 '/mnt/term/d:/music/dirtlabaudio/Dirt Lab Audio 2012/LSDJ -
darkwaxradio091009.mp3'
119033521 '/mnt/term/d:/music/dirtlabaudio/Dirt Lab Audio 2012/LSDJ -
dirtlabaudio051012.mp3'
56699507 '/mnt/term/d:/music/dirtlabaudio/Dirt Lab Audio 2012/Mistic - Dark Wax
Show 16 4 07.mp3'
117857384 '/mnt/term/d:/music/dirtlabaudio/Dirt Lab Audio 2012/Morf Tact - 30 04
07.mp3'
45012114 '/mnt/term/d:/music/dirtlabaudio/Dirt Lab Audio 2012/Node - Dirt Lab
Audio.mp3'
113157933 '/mnt/term/d:/music/dirtlabaudio/Dirt Lab Audio 2012/Sideffect8 -
TheWarAgainstThePublic_Feb092011.mp3'
72527622 '/mnt/term/d:/music/dirtlabaudio/Dirt Lab Audio 2012/Swindler - REDRUM
Sessions 036.mp3'
57604009 '/mnt/term/d:/music/dirtlabaudio/Dirt Lab Audio 2012/Unknown - 006 TRIPLE
SICKZ dark wax rinse 11.mp3'
58097580 '/mnt/term/d:/music/dirtlabaudio/Dirt Lab Audio 2012/Unknown -
BastardLive DarkWax17.mp3'
56669832 '/mnt/term/d:/music/dirtlabaudio/Dirt Lab Audio 2012/Unknown -
BastardpresentsBlastphemik darkwaxradio19 06 2008.mp3'
54484741 '/mnt/term/d:/music/dirtlabaudio/Dirt Lab Audio 2012/Unknown - Fade live
on darkwaxradio com260309.mp3'
59346860 '/mnt/term/d:/music/dirtlabaudio/Dirt Lab Audio 2012/Unknown -
GUMBYLIVEDARKWAXRADIODEC262K8.mp3'
57481509 '/mnt/term/d:/music/dirtlabaudio/Dirt Lab Audio 2012/Unknown -
GUMBYLIVEDARKWAXRADIOOCT22009.mp3'
120304535 '/mnt/term/d:/music/dirtlabaudio/Dirt Lab Audio 2012/Unknown - Onyx
15.mp3'
116439667 '/mnt/term/d:/music/dirtlabaudio/Dirt Lab Audio 2012/Unknown - Redutkor
DarkWaxRadio31.mp3'
57983478 '/mnt/term/d:/music/dirtlabaudio/Dirt Lab Audio 2012/Unknown -
Sacrificialanode Darkwaxradio 091009.mp3'
86505848 '/mnt/term/d:/music/dirtlabaudio/Dirt Lab Audio 2012/Unknown -
Sacrificialanode Darkwaxradio 301009.mp3'
114504098 '/mnt/term/d:/music/dirtlabaudio/Dirt Lab Audio 2012/Unknown - SDS Dirt
Lab Audio 1 15 12.mp3'
57603135 '/mnt/term/d:/music/dirtlabaudio/Dirt Lab Audio 2012/Unknown - TERMIT
DARKWAX RADIO COM 19.mp3'
58299873 '/mnt/term/d:/music/dirtlabaudio/Dirt Lab Audio 2012/Unknown - TERMIT
DARKWAX RADIO COM 24.mp3'
115557355 '/mnt/term/d:/music/dirtlabaudio/Dirt Lab Audio 2012/violent tendencies
- Drum Therapy 46.mp3'
2393878973 '/mnt/term/d:/music/dirtlabaudio/Dirt Lab Audio 2012'
56887296 '/mnt/term/d:/music/dirtlabaudio/Mistic''s radio shows/Dark Wax Show
Season 01 Episode 01.mp3'
57008128 '/mnt/term/d:/music/dirtlabaudio/Mistic''s radio shows/Dark Wax Show
Season 01 Episode 02.mp3'
57741312 '/mnt/term/d:/music/dirtlabaudio/Mistic''s radio shows/Dark Wax Show
Season 01 Episode 03.mp3'
96995328 '/mnt/term/d:/music/dirtlabaudio/Mistic''s radio shows/Dark Wax Show
Season 01 Episode 04.mp3'
56365056 '/mnt/term/d:/music/dirtlabaudio/Mistic''s radio shows/Dark Wax Show
Season 01 Episode 05.mp3'
81979392 '/mnt/term/d:/music/dirtlabaudio/Mistic''s radio shows/Dark Wax Show
Season 01 Episode 06.mp3'
27117568 '/mnt/term/d:/music/dirtlabaudio/Mistic''s radio shows/Dark Wax Show
Season 01 Episode 07.mp3'
44564480 '/mnt/term/d:/music/dirtlabaudio/Mistic''s radio shows/Dark Wax Show
Season 01 Episode 08.mp3'
43702272 '/mnt/term/d:/music/dirtlabaudio/Mistic''s radio shows/Dark Wax Show
Season 01 Episode 09.mp3'
43134976 '/mnt/term/d:/music/dirtlabaudio/Mistic''s radio shows/Dark Wax Show
Season 01 Episode 10.mp3'
43102208 '/mnt/term/d:/music/dirtlabaudio/Mistic''s radio shows/Dark Wax Show
Season 01 Episode 11.mp3'
44328960 '/mnt/term/d:/music/dirtlabaudio/Mistic''s radio shows/Dark Wax Show
Season 01 Episode 12.mp3'
43321344 '/mnt/term/d:/music/dirtlabaudio/Mistic''s radio shows/Dark Wax Show
Season 01 Episode 13.mp3'
42137600 '/mnt/term/d:/music/dirtlabaudio/Mistic''s radio shows/Dark Wax Show
Season 01 Episode 14.mp3'
39501824 '/mnt/term/d:/music/dirtlabaudio/Mistic''s radio shows/Dark Wax Show
Season 02 Episode 01.mp3'
121281401 '/mnt/term/d:/music/dirtlabaudio/Mistic''s radio shows/Dark Wax Show
Season 02 Episode 02.mp3'
119721984 '/mnt/term/d:/music/dirtlabaudio/Mistic''s radio shows/Dark Wax Show
Season 02 Episode 03.mp3'
43640960 '/mnt/term/d:/music/dirtlabaudio/Mistic''s radio shows/Dark Wax Show
Season 02 Episode 04.mp3'
86311040 '/mnt/term/d:/music/dirtlabaudio/Mistic''s radio shows/Dark Wax Show
Season 02 Episode 05.mp3'
86556800 '/mnt/term/d:/music/dirtlabaudio/Mistic''s radio shows/Dark Wax Show
Season 02 Episode 06.mp3'
56295552 '/mnt/term/d:/music/dirtlabaudio/Mistic''s radio shows/Dark Wax Show
Season 02 Episode 07.mp3'
87836800 '/mnt/term/d:/music/dirtlabaudio/Mistic''s radio shows/Dark Wax Show
Season 02 Episode 08.mp3'
1379532281 '/mnt/term/d:/music/dirtlabaudio/Mistic''s radio shows'
96985044
/mnt/term/d:/music/dirtlabaudio/Mistic_feat_Brainwash_DarkWax_Show_episode_4-11.11.09.mp3
3958332084 /mnt/term/d:/music/dirtlabaudio

Tue Oct 17 19:04:51 EDT 2017
match std.getenv("CONTENT_LENGTH")
| `std.Some s: len = std.getv(std.intparse(s), 100*std.KiB)
| `std.None: len = 100 * std.KiB
;;
if len > 100*std.KiB
	-> `std.Err "Input file too long"
;;

Mon Oct 16 23:52:37 EDT 2017
import sys


def longestunique(val):
    has = [False]*255
    start = 0
    end = 0
    best = 0
    while end != len(val):
	c = val[end]
	if has[ord(c)]:
	    has[ord(val[start])] = False
	    start += 1
	else:
	    has[ord(val[end])] = True
	    end += 1
	if end - start + 1 > best:
	    best = end - start
    return best

print(longestunique(sys.argv[1]))

Mon Oct 16 19:18:43 EDT 2017
From: Doug McIlroy <doug@cs.dartmouth.edu>
Date: Mon, 16 Oct 2017 07:58:40 -0400
To: tuhs@tuhs.org
Subject: Re: [TUHS} Running V8 ...
Errors-To: tuhs-bounces@minnie.tuhs.org
Sender: "TUHS" <tuhs-bounces@minnie.tuhs.org>

> How realistic would the experience be to actually running the system
> described in the Unix Programming Environment [v8] if it's actually
running > BSD 4.1...  Thanks for any insights y'all might have on this.

This question bears on a recent thread about favorite flavors of Unix.  My
favorite flavor is Universal Unix, namely the stuff that just works
everywhere.  That's essentially what K&P is about.

That's also what allowed me to use a giant Cray with no instruction
whatsoever.  And to do everyday "programmering" on the previously
inscrutable Macintosh, thanks to OS X.

The advent of non-typewriter input put a damper on Universal Unix.  One has
to learn something to get started with a novel device.  I am impressed,
though, by the breadth of Universal Unix that survives behind those
disparate facades.




Sat Oct 14 20:21:19 EDT 2017
//header
#ifndef FRAMEBUFFER_H
#define FRAMEBUFFER_H
#include "stdint.h"
#include "defs.h"


class FrameBuffer{
	public:
		FrameBuffer();
		void drawFrameBuffer();
		void drawToFrameBuffer(int x, int y, uint16_t color);
		uint16_t frameBuffer[];
	private:
		//uint16_t _x,_y,_w,_h,_detail;
		Adafruit_ILI9341 _tft;
};



#endif

// Source
#include "framebuffer.h"
#include "stdint.h"
#include "Adafruit_GFX.h"
#include "Adafruit_ILI9341.h"
//#include "defs.h"
//#include "common.h"



FrameBuffer::FrameBuffer(tft){_tft = tft;}

void FrameBuffer::drawFrameBuffer(){
	for(uint16_t i = 0; i < screenWidth/detail; i++){//iterate over X
	values
		_tft.startWrite();
		for(uint16_t j = 0; j < screenHeight; j++){//iterate over Y
		values
			_tft.writePixel(screenXoffset+(i*detail), screenYoffset+j,
			frameBuffer[screenWidth*j+i]);
		}
		_tft.endWrite();
	}
}

void FrameBuffer::drawToFrameBuffer(int x, int y, uint16_t color){
	frameBuffer[screenWidth*y + x] = color;
}


//Error

framebuffer.cpp:10: error: expected constructor, destructor, or type conversion
before '(' token
 FrameBuffer::FrameBuffer(tft){_tft = tft;}


Sat Oct 14 20:19:43 EDT 2017
sadf

Fri Oct 13 09:31:37 EDT 2017
root@lede:/# cat /etc/config/network

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd27:70fa:5c1d::/48'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0.1'
	option proto 'static'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option ipaddr '192.168.1.1'

config interface 'wan'
	option ifname 'eth0.2'
	option proto 'dhcp'

config interface 'wan6'
	option ifname 'eth0.2'
	option proto 'dhcpv6'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '1 2 3 4 5t'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '0 5t'

Fri Oct 13 09:26:41 EDT 2017
  config interface 'lan'
	option type 'bridge'
	option ifname 'eth0 eth2'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'


Fri Oct 13 09:23:58 EDT 2017
config 'interface' 'example'
	option 'type' 'bridge'
	option 'proto' 'none'
	option 'ifname' 'eth0 eth2'
	option 'auto' '1'

Fri Oct 13 09:23:48 EDT 2017
config 'interface' 'example'
	option 'type' 'bridge'
	option 'proto' 'none'
	option 'ifname' 'eth0 eth1'
	option 'auto' '1'

next